Truyện Cười BlogTaPhiet KC

Chat Box


--------------:Search

Đang tải...

Chủ Nhật, ngày 30 tháng 10 năm 2011

Các lệnh cơ bản với Router Cisco

Đây là các câu lệnh cơ bản nhất đối với Router , được thực hiện trên Packet Tracer 5.1 :) .
Các bạn mở PT lên , sau đó kéo thả 1 Router phía dưới lên trên màn hình . (Xem hình cuối trang )
Click đôi vào Router đó , chọn CLI , ta được :
--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no


Press RETURN to get started!

Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#enable password cisco
Router(config)#enable secret Darkboy
Router(config)#line console 0
Router(config-line)#password 1990
Router(config-line)#login
Router(config-line)#exit
Router(config)#line vty 0 4
Router(config-line)#password passjcungdc
Router(config-line)#login
Router(config-line)#exit
Router(config)#int
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
Router(config-if)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#exit

Bây giờ với hình minh họa , cùng các câu lệnh trên , mình sẽ giải thích từng dòng một :
Continue with configuration dialog? [yes/no]: no
Dòng này hỏi bạn muốn cấu hình theo chế độ từng dòng hay bằng tay , ta chọn No để tự làm , tùy biến dễ hơn :
Router>enable
Router> cho biết ta đang ở User Mode , khi gõ lệnh Enable sẽ chuyển qua chế độ Privilege Mode .
Router#config terminal
Đây là câu lệnh cho phép ta vào cấu hình toàn cục của Router .
Enter configuration commands, one per line. End with CNTL/Z. Mấy dòng thông báo thế này là tự nó nhảy ra .

Router(config)#enable password Cisco
Router(config)#enable secret Darkboy
Đây là 2 dòng lệnh đặt Password cho Router , ở trên nếu ta đang ở User Mode mà muốn qua Privilege Mode , nếu đặt Pass cho Router thì lần đăng nhập tiếp theo sẽ có yêu cầu đòi PassWord .
Ở đây , password Darkboy sẽ được ưu tiên sử dụng hơn pass Cisco , nếu ta chỉ gõ dòng lệnh thứ 1 , thì pass Cisco sẽ được sử dụng (tức là khi đăng nhập ta sẽ gõ pass này)

Router(config)#line console 0
Router(config-line)#password 1990
Router(config-line)#login
Đây là 1 loại password khác nữa , ta cấu hình Router thật bằng cách cắm dây console giữa CPU và Router . Lúc đăng nhập từ User Mode vào Privilege Mode , ngoài password Cisco (Hay Darkboy) ta sẽ phải nhập thêm password này nữa .
(tại sao lại là line console 0 mà không là 1,2,3 .. thì cái này có lẽ là quy định Cisco , tớ không rõ lắm :D)
Mọi người chú ý thêm
login sau dòng đặt password .
Router(config-line) -> Router(config) : Ta dùng lệnh exit .

Router(config)#line vty 0 4
Router(config-line)#password passjcungdc
Router(config-line)#login
Router(config-line)#exit
Đây là Password dùng cho việc Telnet , khi 1 Router khác muốn vào điều khiển 1 Router này , Router đó phải gõ mật khẩu của enable Password và password này nữa (Telnet ~ Điều khiển mà ta không cần rút dây console từ Router này cắm vào Router khác - mất công :D)

Router(config)#int
(chú ý)
Router(config)#interface fa0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

int phía trên chính là viết tắt interface , ở đó mình nhấn Tab nó sẽ nhảy xuống dòng và trở thành interface đây là chức năng tự điền thêm vào , cho đỡ mất công gõ hết cả dòng , nếu dòng intđủ có nghĩa để phân biệt , nếu có 1 lệnh nào đó ví dụ internet (lệnh này không có à nha :-") thì ấn Tab là tối nghĩa , tại nó không hiểu bạn muốn chọn lệnh nào cả , để đủ cho nó hiểu ta gõ interf, interfa .. cái nào cũng được , miễn lả phân biệt với lại internet (chỉ là ví dụ - không có thật , thực sự gõ int là đủ :D)

Trên Router thì có cổng Fa0/0 , Fa0/1 ... Bây giờ ta đặt địa chỉ cho cổng fa0/1:
ip address 192.168.1.1 255.255.255.0 . 192.168.1.1 là địa chỉ IP , còn 255.255.255.0 là Subnet Mask .
No shut : như các bạn thấy dòng lệnh tự động của Cisco thông báo
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up chính là do dòng No shut này (Làm cho fa0/1 -> up , không bị down - như vậy mới liên lạc được :D)
Chức năng của các cổng Fa đó là liên lạc giữa các Router với nhau , hoặc với Switches .. chính vì thế nó cần có địa chỉ :)

Xong các lệnh , bây giờ là 1 số lưu ý :
- Các lệnh của Router rất nhiều , đây chỉ là những thứ cơ bản nhất .
- Chắc chắn là rất nhiều bạn nếu chưa học CCNA sẽ thắc mắc , ví dụ Privilege Mode là sao ,không No shut có sao không ... Thì mình \trả lời là có những cái nó là quy định , chịu khó chấp nhận vậy , sau này hiểu rõ thì sẽ mày mò thêm , cũng như nếu thêm các giải thích này vào bài viết sẽ bị "chuyên sâu"
, rất khó lĩnh hội (cái này kinh nghiệm bản thân) , ta sẽ bị đi quá xa , và mất tập trung vào thứ chính . Và một số thứ trong này thú thật mình cũng chả hiểu :)) (cái này sẽ nhờ mấy Pro giải thích phía dưới - để tránh loãng bài viêt)

- Đang gõ lệnh , các bạn gõ ? , nó sẽ sổ ra 1 bầy lệnh lạ hoắc , đây là các lệnh trong Mode đó nó có , rất nhiều , cứ gõ thoải mái , không vấn đề :D , không biết gõ tiếp làm sao thì lại gõ ? . Coi như làm quen với lệnh .
- Hình vẽ mình chỉ đưa 2 cái , và có copy tô đậm phần cấu hình ra , nó là phần chính , để trong hình sẽ gây rối cho mọi người .

- Bài viết này mình biết còn nhiều thiếu sót , nên mọi người cứ thắc mắc , phê bình bên dưới , mình sẽ trả lời trong thời gian sớm nhất có thể , và rút kinh nghiệm cho những lần sau .
Xin cảm ơn
>:)>:)>:)>:)>:)>:)>:)
Share/Save/Bookmark

Đăng nhận xét

More →
Chữ đậm Chữ nghiêng Chữ nghiêng 2 Chèn Link Chèn Link Mã hóa code Help ?Nhấn vào biểu tượng hoặc kiểu chữ hoặc chèn link sau đó nhấn nút Chọn rồi copy (Ctrl + C) để paste (Ctrl + V) vào khung viết bình luận. Mã hóa code nếu bạn muốn đưa code vào bình luận.

Chọn Xóa
Top