Truyện Cười BlogTaPhiet KC

Chat Box


--------------:Search

Đang tải...

Chủ Nhật, ngày 30 tháng 10 năm 2011

Các lệnh cấu hình Router

+ Các chế độ cấu hình:
Router> (chế độ user mode)
Router>enable (vào chế độ Privileged EXEC Mode)
Router#configure terminal (vào chế độ Configuration Mode)

+ Cấu hình đặt tên và password cho router:

Router(config)#hostname tên_muốn_đặt (đặt tên cho router)
Router(config)#enable password pass_muốn đặt (cấu hình pass ko mã hóa)
Router(config)#enable secret pass_muốn_đặt (cấu hình pass được mã hóa bằng MD5)

+ Cấu hình các đường truy cập (console, aux và vty)
- Cấu hình cổng console:
Router(config)#line console 0
Router(config-line)#password pass_cho_cổng_console (có thể khác pass của router)
Router(config-line)#login (bắt buộc phải có để chế độ đặt pass cho cổng console có hiệu lực)

- Cấu hình cổng aux:
Router(config)#line aux 0
Router(config-line)#password pass_cho_cổng_aux (có thể khác pass của router)
Router(config-line)#login (bắt buộc phải có để chế độ đặt pass cho cổng console có hiệu lực)

- Cấu hình cổng vty (cổng telnet)

Router(config)#line vty 0 4 (chỉ cấu hình 5 đường telnet trong 1 thời điểm).
Router(config-line)#password pass_cho_cổng_vty (có thể khác pass của router)
Router(config-line)#login (bắt buộc phải có để chế độ đặt pass cho cổng vty có hiệu lực)

+ Câu lệnh để mã hóa tất cả mật khẩu:

Router(config)#service password-encryption

+ Cấu hình địa chỉ ip cho interface:
Router(config)#interface tên_cổng (vào interface)
Router(config-if)#no shutdown (cho phép interface hoạt động)
Router(config-if)#clock rate 64000 (đặt thời gian đồng bộ giữa 2 router, chỉ dùng với đường serial)
Router(config-if)#ip address địa_chỉ_ip subnet_mask (đặt địa chỉ ip cho interface)

+ Cấu hình static route:

Có 2 cách cấu hình Static Route, đó là cấu hình theo "next hop"address và exit interface.
- Cấu hình theo "next hop" address:
Router(config)#ip route địa_chỉ_mạng_muốn_quảng_bá subnet_mask địa_chỉ_ip_của_interface_nối_với_mạng _muốn_quảng_bá.
- Cấu hình theo exit interface:
Router(config)#ip route địa_chỉ_mạng_muốn_quảng_bá subnet_mask interface_nối_với_mạng_muốn_quảng_bá.

+ Cấu hình đường default route:
Router(config)#ip route 0.0.0.0 0.0.0.0 [exit interface/ip address].

+ Cấu hình RIP:
Router(config)#router rip (dùng giao thức định tuyến RIP)
Router(config-router)#network địa_chỉ_ip (địa chỉ mạng muốn quảng bá bằng giao thức RIP)
Router(config-router)#passive-interface tên_cổng (thông tin định tuyến RIP ko đc gửi ra cổng này)
Router(config-router)#version 2 (dùng RIP version 2,mặc định là version 1)

+ Cấu hình EIGRP :
1.Cấu hình cơ bản.
Router(config)#router eigrp eigrp_muốn_đặt ( 1->65535)
Router(config-router)#network IP_mạng_muốn_quảng_bá
Router(config-router)#no auto-summary (ko tự ghép các dải địa chỉ IP thành 1 dải lớn)

- Thay đổi băng thông và tự tổng hợp tuyến trong interface

Router(config-if)#bandwidth kilobits
Router(config-if)#ip summary-address protocol AS network number subnets mask

- Cân bằng tải trong EIGRP

Router(config-router)#variance number

- Quảng bá default route

Cách 1:
Router(config)#ip route 0.0.0.0 0.0.0.0 [interface/nexthop]
Router(config)#redistribute static
Cách 2:
Router(config)#ip default-network network number

Cách 3:
Router(config-if)#ip summary-network eigrp AS number 0.0.0.0 0.0.0.0

- Quảng bá các tuyến khác trong EIGRP (không phải là default)
Router(config-router)#redistribute giao_thức_muốn_quảng_bá ID_metrics k1 k2 k3 k4 k5
Ví dụ: Router(config-router)#redistribute ospf metrics 100 100 100 100 100

- Chia sẻ traffic trong EIGRP

Router(config-router)#traffic share {balanced/min}

- Các lệnh kiểm tra cấu hình EIGRP
show ip eigrp neighbor
show ip eigrp interface
show ip eigrp topology
show ip eigrp traffic
debug eigrp fsm
debug eigrp packet

+ OSPF:
- Cấu hình cơ bản

Router(config)#router ospf ospf_muốn_chọn ( 1->65535)
Router(config-router)#network dải_đại_chỉ_muốn_quảng_bá Wildcard_mask area_ID (thường là area 0)

- Cấu hình priority ở các interface để bầu DR và BDR
Priority càng lớn thì khả năng được bầu làm DR càng cao, ngược với bầu Root brige của Switch, càng nhỏ thì lại càng được bầu.
Router(config)#interface fastethernet 0/0
Router(config-int)#ip ospf priority 55
Sau khi cấu hình xong priority có thể kiểm tra bằng lệnh.
Router# show ip ospf interface f0/0

- Chỉnh sửa lại OSPF cost metric trong mỗi interface

Cost càng nhỏ thì tuyến đó càng được coi là best path
Router(config-int)#ip ospf cost 1

- Cấu hình OSPF Authentication ở các interface và áp dùng vào router
Authentication key được hiểu như là password để các router trong cùng một vùng chia sẻ với nhau.
a. Cấu hình authentication đơn giản
Router(config-if)#ip ospf authentication-key password
Router(config-router)#area area number authentication

b. Cấu hình authentication theo dạng mã hoá, bảo mật cao.
Router(config-if)ip ospf message-digest-key key ID md5 encryption-type key
Router(config-router)#area area ID authentication message-digest



- Cấu hình OSPF timer trong các interface
Router(config-if)ip ospf hello-interval timer
Router(config-if)ip ospf dead-interval timer

- Cấu hình quảng bá một tuyến mặc định trong OSPF
Router(config-router)#default-information originate

- Quảng bà một tuyến khác (không phải là default)
Router(config-router)#redistribute protocols subnets

- Các lệnh show dùng để kiểm tra cấu hình OSPF
show ip protocol
show ip route
show ip ospf
show ip ospf interface
show ip ospf database
show ip ospf neighbor detail
clear ip route *
debug ip ospf events
debug ip ospf adj


- Cấu hình cổng vty (cổng telnet)

Router(config)#line vty 0 4 (chỉ cấu hình 5 đường telnet trong 1 thời điểm).
Router(config-line)#password pass_cho_cổng_vty (có thể khác pass của router)
Router(config-line)#login (bắt buộc phải có để chế độ đặt pass cho cổng vty có hiệu lực) Chỗ này có chút góp ý nhá. Các đòi OS cũ chỉ support 5 đường telnet nhưng giờ các OS mới có tới 16 lận nghĩa là chỗ này phải là Router(config)#line vty 0 15.


+ Cấu hình địa chỉ ip cho interface:
Router(config)#interface tên_cổng (vào interface)
Router(config-if)#no shutdown (cho phép interface hoạt động)
Router(config-if)#clock rate 64000 (đặt thời gian đồng bộ giữa 2 router, chỉ dùng với đường serial)
Router(config-if)#ip address địa_chỉ_ip subnet_mask (đặt địa chỉ ip cho interface)
Chỗ này ở các Interface nên thêm các description vào để phân biệt các interface khác nhau là loạn hết đấy. Các bạn cũng cần phải chú ý chỉ set clock rate khi nó là thiết bị DCE kết nối bằng cổng serial.
Đính chính một chút nha các bạn. Cổng telnet của Router vẫn là 5 tức là từ 0 4, còn của switch mới là 16 tức là từ 0 15.
Mình góp ý nhiêu đó thôi. Các bạn khác có ý gì hay thì đưa ra anh em tham khảo nha.
Share/Save/Bookmark

Đăng nhận xét

More →
Chữ đậm Chữ nghiêng Chữ nghiêng 2 Chèn Link Chèn Link Mã hóa code Help ?Nhấn vào biểu tượng hoặc kiểu chữ hoặc chèn link sau đó nhấn nút Chọn rồi copy (Ctrl + C) để paste (Ctrl + V) vào khung viết bình luận. Mã hóa code nếu bạn muốn đưa code vào bình luận.

Chọn Xóa
Top